summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml26
1 files changed, 21 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 3f573e2..00c790d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,16 +1,32 @@
[tool.poetry]
name = "ATRI"
-version = "0.0.1"
-description = "仅用于自动格式化代码"
+version = "001.105.01"
+description = "A project for ATRI, Usage go-CQHTTP + Nonebot."
authors = ["Kyomotoi <[email protected]>"]
license = "GPLv3"
readme = "README.md"
-homepage = "https://github.com/Kyomotoi/ATRI"
+homepage = "https://atri.kyomotoi.moe/"
repository = "https://github.com/Kyomotoi/ATRI"
-documentation = "https://github.com/Kyomotoi/ATRI/wiki"
+documentation = "https://atri.kyomotoi.moe/"
[tool.poetry.dependencies]
-python = "^3.8"
+python = "3.10"
+aiofiles = "^0.8.0"
+APScheduler = "^3.9.1"
+Pillow = "^9.1.1"
+nonebot2 = "^2.0.0-beta.3"
+nonebot-adapter-onebot = "^2.0.0-beta.1"
+nonebot-plugin-gocqhttp = "^0.5.5"
+psutil = "^5.9.1"
+pytz = "^2022.1"
+PyYAML = "^6.0"
+scikit-image = "^0.19.2"
+tensorflow = "^2.9.1"
+jieba = "^0.42.1"
+tabulate = "^0.8.9"
+wcwidth = "^0.2.5"
+aiohttp = "^3.8.1"
+tortoise-orm = "^0.19.1"
[tool.poetry.dev-dependencies]
black = "^21.4-beta.0"