summaryrefslogtreecommitdiff
path: root/runoff.spec
diff options
context:
space:
mode:
authorRuss Cox <[email protected]>2011-02-19 21:17:55 -0500
committerRuss Cox <[email protected]>2011-02-19 21:17:55 -0500
commitcf4b1ad90bcaeeb0c8458098c87948f61d408f94 (patch)
treeb6385b1d72af5a3e634b94b318fb7e43644493af /runoff.spec
parent9c4fe7ba105c0430c90179fd1e93c3d439a8cbd5 (diff)
downloadxv6-labs-cf4b1ad90bcaeeb0c8458098c87948f61d408f94.tar.gz
xv6-labs-cf4b1ad90bcaeeb0c8458098c87948f61d408f94.tar.bz2
xv6-labs-cf4b1ad90bcaeeb0c8458098c87948f61d408f94.zip
xv6: formatting, cleanup, rev5 (take 2)
Diffstat (limited to 'runoff.spec')
-rw-r--r--runoff.spec26
1 files changed, 17 insertions, 9 deletions
diff --git a/runoff.spec b/runoff.spec
index 8a2b5c9..4d00038 100644
--- a/runoff.spec
+++ b/runoff.spec
@@ -6,8 +6,8 @@ sheet1: left
# pages. The file may start in either column.
#
# "even" and "odd" specify which column a file must start on. "even"
-# means it must start in the left of the two columns. "odd" means it
-# must start in the right of the two columns.
+# means it must start in the left of the two columns (00). "odd" means it
+# must start in the right of the two columns (50).
#
# You'd think these would be the other way around.
@@ -33,23 +33,23 @@ left: spinlock.h # mild preference
even: spinlock.h # mild preference
# This gets struct proc and allocproc on the same spread
-right: proc.h
-odd: proc.h
+left: proc.h
+even: proc.h
# goal is to have two action-packed 2-page spreads,
# one with
# userinit growproc fork exit wait
# and another with
# scheduler sched yield forkret sleep wakeup1 wakeup
-left: proc.c # VERY important
-odd: proc.c # VERY important
+right: proc.c # VERY important
+even: proc.c # VERY important
# A few more action packed spreads
# page table creation and process loading
# walkpgdir mappages setupkvm vmenable switch[ku]vm inituvm loaduvm
# process memory management
# allocuvm deallocuvm freevm
-right: vm.c
+left: vm.c
odd: vm.c
# kalloc.c either
@@ -69,17 +69,25 @@ odd: vm.c
# file.h either
# fs.h either
# fsvar.h either
-left: ide.c
+# left: ide.c # mild preference
even: ide.c
# odd: bio.c
+
+# with fs.c starting on 2nd column of a left page, we get these 2-page spreads:
+# ialloc iupdate iget idup ilock iunlock iput iunlockput
+# bmap itrunc stati readi writei
+# namecmp dirlookup dirlink skipelem namex namei
+# fielinit filealloc filedup fileclose filestat fileread filewrite
+# starting on 2nd column of a right page is not terrible either
odd: fs.c # VERY important
+left: fs.c # mild preference
# file.c either
# exec.c either
# sysfile.c either
# even: pipe.c # mild preference
# string.c either
-left: kbd.h
+# left: kbd.h # mild preference
even: kbd.h
even: console.c
odd: sh.c