summaryrefslogtreecommitdiff
path: root/runoff.spec
diff options
context:
space:
mode:
PDF at http://am.lcs.mit.edu/~rsc/xv6.pdf
Various changes made while offline. + bwrite sector argument is redundant; use b->sector. + reformatting of files for nicer PDF page breaks + distinguish between locked, unlocked inodes in type signatures + change FD_FILE to FD_INODE + move userinit (nee proc0init) to proc.c + move ROOTDEV to param.h + always parenthesize sizeof argument
Diffstat (limited to 'runoff.spec')
-rw-r--r--runoff.spec59
1 files changed, 49 insertions, 10 deletions
diff --git a/runoff.spec b/runoff.spec
index 53e98ee..9d0ad31 100644
--- a/runoff.spec
+++ b/runoff.spec
@@ -1,11 +1,50 @@
-even: mmu.h
-even: bootasm.S
-even: bootother.S
-even: bootmain.c
+# types.h either
+# param.h either
+# defs.h either
+# x86.h either
+# asm.h either
+# mmu.h either
+# elf.h either
+# mp.h either
+
+even: bootasm.S # mild preference
+even: bootother.S # mild preference
+# bootmain.c either
even: main.c
-even: spinlock.c
-even: proc.h
-even: proc.c
-odd: kalloc.c
-even: trap.c
-odd: bio.c
+# mp.c don't care at all
+even: initcode.S
+odd: init.c
+
+# spinlock.h either
+# spinlock.c either
+even: proc.h # mild preference
+even: proc.c # VERY important
+# setjmp.S either
+# kalloc.c either
+
+# syscall.h either
+# trapasm.S either
+# traps.h either
+even: trap.c # important
+# vectors.pl either
+# syscall.c either
+# sysproc.c either
+
+# buf.h either
+# dev.h either
+# fcntl.h either
+# stat.h either
+# file.h either
+# fs.h either
+# fsvar.h either
+# even: ide.c
+# odd: bio.c
+odd: fs.c # VERY important
+# file.c either
+# exec.c either
+# sysfile.c either
+
+even: pipe.c # mild preference
+# string.c either
+# even: console.c
+